Android OS Vulnerabilities Could Allow for Remote Code Execution

by | Mar 2, 2021 | Advisories

Multiple vulnerabilities have been discovered in the Google Android operating system (OS), the most severe of which could allow for remote code execution. Android is an operating system developed by Google for mobile devices, including, but not limited to, smartphones, tablets, and watches. Successful exploitation of the most severe of these vulnerabilities could allow for remote code execution within the context of a privileged process. Depending on the privileges associated with this application, an attacker could then install programs; view, change, or delete data; or create new accounts with full user rights. If this application has been configured to have fewer user rights on the system, exploitation of the most severe of these vulnerabilities could have less impact than if it was configured with administrative rights.

THREAT INTELLIGENCE: There are currently no reports of these vulnerabilities being exploited in the wild.

SYSTEMS AFFECTED:

  • Android OS builds utilizing Security Patch Levels issued prior to March 5, 2021

RISK:
Government:

  • Large and medium government entities: High
  • Small government entities: High

Businesses:

  • Large and medium business entities: High
  • Small business entities: High

Home users: High

TECHNICAL SUMMARY:

Multiple vulnerabilities have been discovered in Google Android OS, the most severe of which could allow for remote code execution within the context of a privileged process. Details of these vulnerabilities are as follows:

  • An elevation of privilege vulnerability in Android runtime. (CVE-2021-0395)
  • Multiple elevation of privilege vulnerabilities in Framework. (CVE-2021-0391, CVE-2021-0398)
  • Multiple remote code execution vulnerabilities in System. (CVE-2021-0397, CVE-2017-14491, CVE-2021-0393, CVE-2021-0396)
  • Multiple elevation of privilege vulnerabilities in System. (CVE-2021-0390, CVE-2021-0392, CVE-2021-0394)
  • An information disclosure vulnerabilities in System. (CVE-2021-0394)
  • A vulnerabilities in Google Play system updates (CVE-2021-0390)
  • A high severity vulnerabilities in Kernel components (CVE-2020-0399)
  • Multiple high severity vulnerabilities in Qualcomm components (CVE-2020-11233, CVE-2020-11129, CVE-2020-111308, CVE-2020-11309)
  • Multiple critical severity vulnerabilities in Qualcomm closed-source components (CVE-2020-11192 CVE-2020-11204, CVE-2020-11218, CVE-2020-11227, CVE-2020-11228)
  • Multiple high severity vulnerabilities in Qualcomm closed-source components (CVE-2020-11165, CVE-2020-11166, CVE-2020-11171, CVE-2020-11178, CVE-2020-11186, CVE-2020-11188, CVE-2020-11189, CVE-2020-11190, CVE-2020-11194, CVE-2020-11195, CVE-2020-11198, CVE-2020-11199, CVE-2020-11220, CVE-2020-11221, CVE-2020-11222, CVE-2020-11226, CVE-2020-11299)

Successful exploitation of the most severe of these vulnerabilities could allow for remote code execution within the context of a privileged process. Depending on the privileges associated with this application, an attacker could then install programs; view, change, or delete data; or create new accounts with full user rights. If this application has been configured to have fewer user rights on the system, exploitation of the most severe of these vulnerabilities could have less impact than if it was configured with administrative rights.

RECOMMENDATIONS:

We recommend the following actions be taken:

  • Apply appropriate updates by Google Android or mobile carriers to vulnerable systems, immediately after appropriate testing.
  • Remind users to only download applications from trusted vendors in the Play Store.
  • Remind users not to visit un-trusted websites or follow links provided by unknown or un-trusted sources.
  • Inform and educate users regarding threats posed by hypertext links contained in emails or attachments, especially from un-trusted sources.

REFERENCES:
Google Android:
https://source.android.com/security/bulletin/2021-03-01

CVE:
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-14491

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-11165

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-11166

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-11171

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-11178

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-11186

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-11188

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-11189

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-11190

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-11192

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-11194

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-11195

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-11198

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-11199

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-11204

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-11218

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-11220

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-11221

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-11222

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-11223

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-11226

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-11227

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-11228

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-11290

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-11299

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-11308

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-11309

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-0390

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-0391

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-0392

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-0393

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-0394

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-0395

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-0396

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-0397

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-0398

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-0399